Invalid Response

Home Forums M2M Support Forum Invalid Response

This topic contains 5 replies, has 2 voices, and was last updated by  Admin 6 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #11056 Reply

    Ryan Moore

    I’m trying to troubleshoot a MultiModem GPRS with a serial connection. I can connect with Hyper terminal with no problem and with SecureCRT. I have tried the tool in IE and Chrome with no success here is my Java Log;
    Java Plug-in 10.51.2.13
    Using JRE version 1.7.0_51-b13 Java HotSpot(TM) Client VM
    User home directory = C:\Users\Ryan
    —————————————————-
    c: clear console window
    f: finalize objects on finalization queue
    g: garbage collect
    h: display this help message
    l: dump classloader list
    m: print memory usage
    o: trigger logging
    q: hide console
    r: reload policy configuration
    s: dump system and deployment properties
    t: dump thread list
    v: dump thread stack
    x: clear classloader cache
    0-5: set trace level to <n>
    —————————————————-
    Missing Application-Name manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/ATCommandTester_v26.jar
    Missing Permissions manifest attribute in main jar: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/ATCommandTester_v26.jar
    Missing Permissions manifest attribute in main jar: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/ATCommandTester_v26.jar
    Stable Library
    =========================================
    Native lib Version = RXTX-2.1-7
    Java lib Version = RXTX-2.1-7
    COM4 – Serial
    COM4
    PortIdentifier is gnu.io.CommPortIdentifier@1f23303

    commPort is //./COM4

    AT

    Please Help

    #11058 Reply

    Admin
    Keymaster

    Hi,
    Can you please send the settings for hyperterminal?
    Bits per second, Data bits, Parity, Stop bits & Flow control.

    AT Command Tester tool currently does not set the flow control. Can you please check if you set the flow control to ‘None’, whether you could still connect to modem?

    • This reply was modified 6 years ago by  Admin.
    • This reply was modified 6 years ago by  Admin.
    #11061 Reply

    Ryan Moore

    My settings in Hyperterminal are 9800,8,none,1 with no flow control and it will respond with the AT command.

    #11063 Reply

    Admin
    Keymaster

    You meant port speed at 9600?

    #11064 Reply

    Ryan Moore

    Yes the bit speed is 9600, it doesn’t seem to matter to Hyperterminal what the bit speed is all available seems to work.

    #11066 Reply

    Admin
    Keymaster

    That means the device is set to work for autobaud so that it can work on any speeds on the host side..
    AT Command Tester works with devices set for autobaud as well..

    Just as a test, can you configure your modem to work on fixed speed to check if the detection in autobaud
    is the problem.In your hyperrminal, type

    AT+IPR=19200

    Then disconnect your hyperterminal, and connect through AT Command Tester with 19200 as the port speed..

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: Invalid Response
Your information: