Invalid or no response from the device

Home Forums M2M Support Forum Invalid or no response from the device

This topic contains 25 replies, has 2 voices, and was last updated by  Mojako 6 years, 2 months ago.

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • #3883 Reply

    Mai

    AT tester won’t connect to my device. There is a message “Invalid or no response from the device. Please check the modem port and the baud rate.Disconnecting port COM5”, but my laptop and arduino IDE can connect to it.

    What should I do and what is the problem? Thanks

    #3884 Reply

    Admin
    Keymaster

    How are you connecting through your laptop? Through Hyperterminal? Please make sure Arduino IDE or any other application that you’re using to connect to the device is closed. Please check the baud rate on the AT Command Tester. Also, if you’re using an Arduino shield, please read this,

    Using AT Command Tester with Arduino boards

    #3885 Reply

    Mai

    I’m using the arduino uno board with the GPRS seeedstudio shield is connected to the laptop through a USB cable. I uploaded the sketch through IDE, set the baud rate 19200 for both the sketch and AT tester. There is still the message “invalid or no response from the device” and AT tester won’t connect. I did close every applications connecting to the device.

    #3886 Reply

    Admin
    Keymaster

    I assume you loaded this sketch. Are you able to confirm that the device itself is configured for 19200 baud.

    //Serial Relay – Arduino will patch a
    //serial link between the computer and the GPRS Shield
    //at 19200 bps 8-N-1
    //Computer is connected to Hardware UART
    //GPRS Shield is connected to the Software UART

    #include <softwareserial .h>
    SoftwareSerial mySerial(2,3);
     
    void setup()
     {
     Serial.begin(19200);
     //Serial.println(“Begin”);
     mySerial.begin(19200);
     
    }
     
    void loop()
     {
     if (mySerial.available())
     Serial.write(mySerial.read());
     if (Serial.available())
     mySerial.write(Serial.read());
     
    }
    • This reply was modified 6 years, 3 months ago by  Admin.
    • This reply was modified 6 years, 3 months ago by  Admin.
    • This reply was modified 6 years, 3 months ago by  Admin.
    • This reply was modified 6 years, 3 months ago by  Admin.
    • This reply was modified 6 years, 3 months ago by  Admin.
    • This reply was modified 6 years, 3 months ago by  Admin.
    • This reply was modified 6 years, 3 months ago by  Admin.
    • This reply was modified 6 years, 3 months ago by  Admin.
    • This reply was modified 6 years, 3 months ago by  Admin.
    #3887 Reply

    Mai

    Yea I uploaded that sketch. I found this on a forum

    In your case there are two places this could be happening: between the Arduino and the SIM900, or between the Arduino and your PC (e.g. your terminal isn’t set to talk at 19200 baud).
    I assume that you already verified that your Arduino and PC can communicate properly. (You did, right?)

    The SIM900 can be set to communicate at a specific baud rate, or in an “automatic” mode. The mode and baud rate can be stored in the SIM900, and it will remember them across power cycles (i.e. it doesn’t revert to some factory default when powered up or reset). When it’s in “automatic” mode, it expects to receive the character ‘A’ (capital A) at the beginning of the communication to figure out the baud rate.

    I see two options that may explain your situation:
    1. The SIM900 is in “automatic” mode and you don’t send it a capital A at the beginning of your messages.
    2. The SIM900 is in fixed baud rate that you didn’t try.

    I don’t know how to get the baud rate of SIM900 if I’m not able to talk to it. I’ve played around with different baud rate but none of them worked.

    #3888 Reply

    Admin
    Keymaster

    You can do this to determine the SIM900 baud rate,
    Upload the TestModem script from the Arduino IDE (File->Examples->GSM->Tools).
    Open the ‘Serial Monitor’.

    In the TestModem script, try different baud rate settings (9600,14400,19200,28800,34800,57600,115200).
    After you change the baud rate, you need to re-load the sketch each time. Also set the same baud rate for the ‘Serial Monitor’ setting.

    void setup()
    {
    // initialize serial communications and wait for port to open:
    Serial.begin(9600); //Try 9600,14400,19200,28800,34800,57600,115200 values here
    while (!Serial) {
    ; // wait for serial port to connect. Needed for Leonardo only
    }

    When the baud on the sketch matches the baud rate on the SIM900 modem, you’d see sucessful modem connection is established and the IMEI is read correctly.

    #3891 Reply

    Mai

    I’ve tried all the baud rates and I only got “Starting modem test…ERROR, no modem answer.
    Checking IMEI…Error: Could not get IMEI” or garbage values.

    Should I get a new shield? 😀

    #3892 Reply

    Don

    I cannot upload the sketch to the Arduino. I believe something is wrong in the #include statement.

    #3893 Reply

    Admin
    Keymaster

    Don,
    Are you referring to the TestModem sketch? Since this is provided with the Arduino IDE, i’d expect the syntax to be correct.. What error are you seeing?

    #4310 Reply

    Muhammad Ali

    same problem here, using arduino uno and saeed gprs 2.0 shield . tried many things. error is the same
    “Sending AT query..

    Invalid or no response from the device. Please check the modem port and the baud rate.Disconnecting port COM21.

    the port number is correct. baud rate is correct.
    tried many codes including the one given above. this just isnt working and i am getting frustrated :@
    anyone?

    p.s i think the code is not correct , it should be
    #include <SoftwareSerial.h>

    #4358 Reply

    Admin
    Keymaster

    Hi Muhammad,
    Thanks for pointing out the issue with the include file. Have your tried using the TestModem script from the Arduino IDE (File->Examples->GSM->Tools)?

    #4370 Reply

    Muhammad Ali

    i did run the testModem example and i got this
    Starting modem test…ERROR, no modem answer.
    Checking IMEI…Error: Could not get IMEI
    the shield is busted?

    #4501 Reply

    Admin
    Keymaster

    When you ran the TestModem script, did you try different port speed settings?
    FYI, you need to re-load the sketch each time you change the port speed.

    
    void setup()
     {
     // initialize serial communications and wait for port to open:
     Serial.begin(9600); //Try 9600,14400,19200,28800,34800,57600,115200 values here
     while (!Serial) {
     ; // wait for serial port to connect. Needed for Leonardo only
     }

    Can you please provide a AT Command Tester log as detailed in the link below,

    How to enable logging for AT Command Tester Tool?

    #5090 Reply

    Jerry

    I have the exact same issue with the exact same board (Seedstudio’s GPRS V2.0)
    Here is my log

    Java Plug-in 10.25.2.17
    Using JRE version 1.7.0_25-b17 Java HotSpot(TM) Client VM
    User home directory = C:\Users\Jerry
    —————————————————-
    c: clear console window
    f: finalize objects on finalization queue
    g: garbage collect
    h: display this help message
    l: dump classloader list
    m: print memory usage
    o: trigger logging
    q: hide console
    r: reload policy configuration
    s: dump system and deployment properties
    t: dump thread list
    v: dump thread stack
    x: clear classloader cache
    0-5: set trace level to <n>
    —————————————————-
    Missing Permissions manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/ATCommandTester_v14.jar
    Missing Codebase manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/ATCommandTester_v14.jar
    Missing Permissions manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/ATCommandTester_v14.jar
    Missing Codebase manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/ATCommandTester_v14.jar
    Missing Permissions manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/ATCommandTester_v14.jar
    Missing Codebase manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/ATCommandTester_v14.jar
    Missing Permissions manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/RXTXcomm.jar
    Missing Codebase manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/RXTXcomm.jar
    Missing Permissions manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/RXTXcomm.jar
    Missing Codebase manifest attribute for: https://www.m2msupport.net/m2msupport/wp-content/themes/admired/RXTXcomm.jar
    Stable Library
    =========================================
    Native lib Version = RXTX-2.1-7
    Java lib Version = RXTX-2.1-7
    COM1 – Serial
    COM7 – Serial
    COM1
    COM7
    PortIdentifier is gnu.io.CommPortIdentifier@1373a71

    commPort is //./COM7

    #5091 Reply

    Jerry

    When I run the modem tester It tells me no modem answer and could not get IMEI. I changed the bps rate and uploaded multiple speeds onto my board multiple times. I then change the read rate on my serial port and they all give me the same results. Would this have anything to do with an incompatible SIM card? I’ve never worked with GSM/GPRS shields before so I really don’t know where the issue could arise.

Viewing 15 posts - 1 through 15 (of 26 total)
Reply To: Invalid or no response from the device
Your information: