AT+COPS? command response

Home Forums M2M Support Forum AT+COPS? command response

This topic contains 2 replies, has 2 voices, and was last updated by  sadik 6 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6222 Reply

    sadik

    Hi,
    I am using ublox sarag350 gprs module,
    After i send AT+COPS? command i get +COPS: 0 OK, response from module, but i think i is not correct response in datasheet write response of this command is +COPS: x,y,”abcd”,z OK,
    Why i get this response ?

    thanks,

    #6224 Reply

    Admin
    Keymaster

    The response format for AT+COPS? is,
    +COPS: <mode>[,<format>,<oper>[,<AcT>]]

    Read command returns the current mode, the currently selected operator and the current Access Technology. If no operator is selected, <format>, <oper> and <act> are omitted.

    So it looks like the module is not finding any network signal,

    //Check the signal strength
    AT+CSQ

    //Check the registration status
    AT+CREG?

    What does above return?

    • This reply was modified 6 years, 2 months ago by  Admin.
    #6448 Reply

    sadik

    thanks, the problem is about my module, i do not know why but it is break down, when i work with new module after second or third trying this command i get correct response from module,

    In first trying module send +COPS: 0 but in next trying it give correct response,

    thanks,

Viewing 3 posts - 1 through 3 (of 3 total)
Reply To: AT+COPS? command response
Your information: